(address . guix-patches@gnu.org)(name . Philip McGrath)(address . philip@philipmcgrath.com)
This release mitigates CVE-2023-44487.
* gnu/packages/web.scm (nghttp2-1.57): New variable.
(nghttp2)[replacement]: Use it.
---
I've never attempted to create a graft before, and I have **definitely not**
tested this adequately, but `guix refresh` says:
Toggle quote (3 lines)
> Building the following 7989 packages would ensure 20638 dependent packages
> are rebuilt:
so it seems like a graft would be needed.
The upstream nghttp2 advisory about the impact of CVE-2023-44487 is at:
Philip
gnu/packages/web.scm | 14 ++++++++++++++
1 file changed, 14 insertions(+)
Toggle diff (36 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b46286c690..4a66fada51 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -7958,6 +7958,7 @@ (define-public nghttp2
(package
(name "nghttp2")
(version "1.49.0")
+ (replacement nghttp2-1.57)
(source
(origin
(method url-fetch)
@@ -8068,6 +8069,19 @@ (define-public nghttp2-for-node
(("print \\(ver >= '3\\.8'\\)")
"print (tuple(map(int, ver.split('.'))) >= (3,8))")))))))))))
+(define-public nghttp2-1.57
+ (package
+ (inherit nghttp2)
+ (version "1.57.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/nghttp2/nghttp2/"
+ "releases/download/v" version "/"
+ "nghttp2-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0n598w7w8rqdqiay2fad3a11253hibakan5c4vjkpx09648v044j"))))))
+
(define-public hpcguix-web
(package
(name "hpcguix-web")
base-commit: fed6ac2ae182597a492b17a29ed8b26986498755
--
2.41.0