(address . guix-patches@gnu.org)(name . B. Wilson)(address . elaexuotee@wilsonb.com)
* gnu/packages/k-lang.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
---
gnu/local.mk | 1 +
gnu/packages/k-lang.scm | 89 +++++++++++++++++++++++++++++++++++++++++
2 files changed, 90 insertions(+)
create mode 100644 gnu/packages/k-lang.scm
Toggle diff (109 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 924d497057..a4c2c8cda9 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -362,6 +362,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/julia-jll.scm \
%D%/packages/julia-xyz.scm \
%D%/packages/jupyter.scm \
+ %D%/packages/k-lang.scm \
%D%/packages/kawa.scm \
%D%/packages/kde.scm \
%D%/packages/kde-frameworks.scm \
diff --git a/gnu/packages/k-lang.scm b/gnu/packages/k-lang.scm
new file mode 100644
index 0000000000..0c49168639
--- /dev/null
+++ b/gnu/packages/k-lang.scm
@@ -0,0 +1,89 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 B. Wilson <elaexuotee@wilsonb.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages k-lang)
+ #:use-module (gnu packages readline)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix git-download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix utils))
+
+(define-public ngn-k
+ (let ((commit "cb36213657b6c5b2fe3bb1c88c4de7fe975f84ed")
+ (revision "1"))
+ (package
+ (name "ngn-k")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/ngn/k.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1140avqsqaa1pyh937rcd04snbkcgngmkg3dkmsbj6kw0jnrgf1z"))))
+ (build-system gnu-build-system)
+ (inputs (list rlwrap))
+ (arguments
+ `(#:make-flags (list (string-append "CC=" ,(cc-for-target)))
+ #:test-target "t"
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (k (string-append out "/k")))
+ (substitute* "repl.k"
+ (("^#!k") (string-append "#!" k "\n"))))))
+ (replace 'build
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (let ((build-target "k"))
+ (apply invoke "make" `(,@make-flags ,build-target)))))
+ (replace 'install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (k (string-append bin "/k"))
+ (rlwrap (string-append
+ (assoc-ref inputs "rlwrap")
+ "/bin/rlwrap")))
+
+ (define* (rlwrap-prog prog #:key rlwrap (sh (which "bash")))
+ (let* ((real-prog (string-append (dirname prog) "/."
+ (basename prog) "-real"))
+ (prog-tmp (string-append real-prog "-tmp")))
+ (link prog real-prog)
+ (call-with-output-file prog-tmp
+ (lambda (port)
+ (format port
+ "#!~a~%exec -a \"$0\" \"~a\" \"~a\" \"$@\"~%"
+ sh rlwrap (canonicalize-path real-prog))))
+ (chmod prog-tmp #o755)
+ (rename-file prog-tmp prog)))
+
+ (mkdir-p bin)
+ (copy-file "repl.k" (string-append bin "/krepl"))
+ (copy-file "k" k)
+ (rlwrap-prog k #:rlwrap rlwrap)))))))
+ (home-page "https://codeberg.org/ngn/k")
+ (synopsis "Implementation of the K6 vector programming language")
+ (description "ngn/k is a simple fast vector programming language, an
+implementation of the K6 dialect of K.")
+ (license license:agpl3))))
--
2.41.0