(address . guix-patches@gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
Project main page: https://mhogomchungu.github.io/sirikali/
Project GitHub: https://github.com/mhogomchungu/sirikali
Comment: SiriKali provides a user friendly GUI for managing
encrypted folders and supports 'cloud friendly' encryption
such as CryFS, where the encrypted contents are split across
multiple encrypted blocks. These blocks only update as their
respective contents are changed, allowing for easier syncing
across network links by simplifying resumption of interrupted
transfers and providing smaller units for differential
transfer deltas.
---
gnu/packages/sirikali.scm | 59 +++++++++++++++++++++++++++++++++++++++
1 file changed, 59 insertions(+)
create mode 100644 gnu/packages/sirikali.scm
Toggle diff (69 lines)
diff --git a/gnu/packages/sirikali.scm b/gnu/packages/sirikali.scm
new file mode 100644
index 0000000000..a81775f0ce
--- /dev/null
+++ b/gnu/packages/sirikali.scm
@@ -0,0 +1,59 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Aaron Covrig <aaron.covrig.us@ieee.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages sirikali)
+ #:use-module (guix git-download)
+ #:use-module (guix packages)
+ #:use-module (guix build-system cmake)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages gnome)
+ #:use-module (gnu packages gnupg)
+ #:use-module (gnu packages password-utils)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages check)
+ #:use-module ((guix licenses)
+ #:prefix license:))
+
+(define-public sirikali
+ (package
+ (name "sirikali")
+ (version "1.5.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mhogomchungu/sirikali")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1l52s8rxkfcxcx3s2fnsh08wy6hhjjvp7gcggdi84aqc4dq3rdnm"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f ;No tests
+ #:configure-flags '("-DQT5=true" "-DCMAKE_BUILD_TYPE=RELEASE")))
+ (inputs (list xdg-utils libpwquality libgcrypt libsecret qtbase-5))
+ (native-inputs (list pkg-config))
+ (home-page "https://mhogomchungu.github.io/sirikali/")
+ (synopsis
+ "GUI front end to sshfs, ecryptfs, cryfs, gocryptfs, securefs, fscrypt and encfs")
+ (description "@dfn{SiriKali} is a Qt/C++ GUI application that manages
+ecryptfs, cryfs, encfs, gocryptfs, fscrypt and securefs
+based encrypted folders")
+ (license (list license:gpl3 license:gpl2))))
base-commit: cfe55b220a2e21ec6314acd2fbaa5a780ea77afc
--
2.41.0