(address . guix-patches@gnu.org)(name . Cayetano Santos)(address . csantosb@inventati.org)
* gnu/packages/emacs-xyz.scm (emacs-mastodon): Update to 1.0.0-1.20dec88.
---
gnu/packages/emacs-xyz.scm | 60 ++++++++++++++++++++------------------
1 file changed, 31 insertions(+), 29 deletions(-)
Toggle diff (75 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e8d1ac6034..0bd4ff93bc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -32420,35 +32420,37 @@ (define-public emacs-wc-mode
(license license:gpl3+)))
(define-public emacs-mastodon
- (package
- (name "emacs-mastodon")
- (version "1.0.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://codeberg.org/martianh/mastodon.el")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "13swcbvwhjl8ksrgzvmfafkgd3iz8znk49bs1n48w3g9qvh097w7"))))
- (build-system emacs-build-system)
- (arguments
- (list #:phases
- #~(modify-phases %standard-phases
- ;; Move the source files to the top level, which is included in
- ;; the EMACSLOADPATH.
- (add-after 'unpack 'move-source-files
- (lambda _
- (let ((el-files (find-files "./lisp" ".*\\.el$")))
- (for-each (lambda (f)
- (rename-file f (basename f)))
- el-files)))))))
- (propagated-inputs
- (list emacs-request))
- (home-page "https://codeberg.org/martianh/mastodon.el")
- (synopsis "Emacs client for Mastodon")
- (description "@code{mastodon.el} is an Emacs client for Mastodon, the
+ (let ((commit "20dec8871c9bb5f5e418bfc197e7533b5e3065e3")
+ (revision "1"))
+ (package
+ (name "emacs-mastodon")
+ (version (git-version "1.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/martianh/mastodon.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "15cfjny99yw5frdp8nlyazlwgscvfvbinsj0fbdfprxf50k2zjs6"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ ;; Move the source files to the top level, which is included in
+ ;; the EMACSLOADPATH.
+ (add-after 'unpack 'move-source-files
+ (lambda _
+ (let ((el-files (find-files "./lisp" ".*\\.el$")))
+ (for-each (lambda (f)
+ (rename-file f (basename f)))
+ el-files)))))))
+ (propagated-inputs
+ (list emacs-request emacs-ts emacs-persist))
+ (home-page "https://codeberg.org/martianh/mastodon.el")
+ (synopsis "Emacs client for Mastodon")
+ (description "@code{mastodon.el} is an Emacs client for Mastodon, the
federated microblogging social network.")
(license license:gpl3+)))
base-commit: c173819c8e5235ce02d60b79bd88b10023a7c614
--
2.41.0