Thank you.
I am attempting to update the patch series, but now multiple
dependencies are failing to build due to version incompatibilities
or failing tests.
I will try again when I have more time to track down all of these
issues.
Ludovic Courtès <ludo@gnu.org> writes:
Toggle quote (88 lines)
> Hi Peter,
>
> Overall the patch series LGTM, with one nitpick:
>
> peter@polidoro.io skribis:
>
>
> [...]
>
>> + (build-system pyproject-build-system)
>> + (arguments
>> + `(#:tests? #f)) ; FIXME: PermissionError: [Errno 13]
>> Permission denied: '/homeless-shelter'
>
> Consider adding a phase that does (setenv "HOME" (getcwd)) or
> similar to
> address this issue so you can run the test. Shipping an
> untested
> package is something we try to avoid.
>
>> + (home-page "https://platformio.org")
>> + (synopsis
>> + "Your Gateway to Embedded Software Development Excellence.
>> Unlock the true
>> potential of embedded software development with PlatformIO's
>> collaborative
>> ecosystem, embracing declarative principles, test-driven
>> methodologies, and
>> modern toolchains for unrivaled success.")
>> + (description
>> + "Your Gateway to Embedded Software Development
>> Excellence. Unlock the true
>> +potential of embedded software development with
>> @code{PlatformIO's}
>> +collaborative ecosystem, embracing declarative principles,
>> test-driven
>> +methodologies, and modern toolchains for unrivaled success.")
>> + (license license:asl2.0)))
>
> Please replace the marketing language with an actual synopsis
> and a
> description, following the guidelines at:
>
> https://guix.gnu.org/manual/devel/en/html_node/Synopses-and-Descriptions.html
>
> ‘guix lint’ may also diagnose obvious issues.
>
>> - (url "https://github.com/john30/ebusd")
>> - (commit version)))
>> + (url "https://github.com/john30/ebusd")
>> + (commit version)))
>> (file-name (string-append name "-" version
>> "-checkout"))
>> (sha256
>> (base32
>> @@ -1491,14 +1529,14 @@ (define-public ebusd
>> ("autoconf" ,autoconf)
>> ("config"
>> ,(origin
>> - (method git-fetch)
>> - (uri (git-reference
>> - (url
>> "https://github.com/john30/ebusd-configuration")
>> - (commit
>> "666c0f6b9c4d7545eff7f43ab28a1c7baeab7913")))
>> - (file-name "config-checkout")
>> - (sha256
>> - (base32
>> -
>> "0yxnx8p4lbk614l16854r9s9d8s9c7ixgczfs8mph94xz0wkda7x"))))))
>> + (method git-fetch)
>> + (uri (git-reference
>> + (url
>> "https://github.com/john30/ebusd-configuration")
>> + (commit
>> "666c0f6b9c4d7545eff7f43ab28a1c7baeab7913")))
>> + (file-name "config-checkout")
>> + (sha256
>> + (base32
>> +
>> "0yxnx8p4lbk614l16854r9s9d8s9c7ixgczfs8mph94xz0wkda7x"))))))
>
> Looks like these were unintended changes.
>
> Could you please send an updated patch series?
>
> Thanks,
> Ludo’.