(address . guix-patches@gnu.org)(name . raingloom)(address . raingloom@riseup.net)
From: raingloom <raingloom@riseup.net>
* gnu/packages/ocaml.scm (ocaml-mirage-runtime): New variable.
---
gnu/packages/ocaml.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
Toggle diff (34 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 1cc930292c..e0e6a7e1cb 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3717,6 +3717,27 @@ (define-public ocaml-functoria-runtime
"This is the runtime support library for code generated by functoria.")
(license license:isc)))
+(define-public ocaml-mirage-runtime
+ (package
+ (inherit ocaml-functoria-runtime)
+ (name "ocaml-mirage-runtime")
+ (build-system dune-build-system)
+ (arguments
+ '(#:package "mirage-runtime"
+ ;; TODO again, wants opam, other tests seem to pass
+ ;; look for a way to disable tests that want network access
+ #:tests? #f))
+ (propagated-inputs (list ocaml-ipaddr ocaml-functoria-runtime ocaml-fmt
+ ocaml-logs ocaml-lwt))
+ (native-inputs (list ocaml-alcotest))
+ (home-page "https://github.com/mirage/mirage")
+ (synopsis
+ "The base MirageOS runtime library, part of every MirageOS unikernel")
+ (description
+ "This package provides a bundle of useful runtime functions for
+applications built with MirageOS")
+ (license license:isc)))
+
(define-public ocaml-ocurl
(package
(name "ocaml-ocurl")
--
2.38.1