(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
* guix/channels.scm (<channel>): Add channel description field and
comment disambiguating the type expected in an introduction field.
* doc/guix.scm (Invoking guix describe): Add channel description field
to channels record instance example.
This commit adds an optional description field to a channel intended to
describe the channel. Its purpose is similar to the description field
in a <package> record.
---
doc/guix.texi | 2 ++
guix/channels.scm | 15 ++++++++-------
2 files changed, 10 insertions(+), 7 deletions(-)
Toggle diff (41 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 24d99cbf24..483d2fbaa4 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -5063,6 +5063,8 @@ $ guix describe -f channels
(list (channel
(name 'guix)
(url "https://git.savannah.gnu.org/git/guix.git")
+ (description "The main GNU Guix channel providing the core
+package collection along with Guix and its documentation.")
(commit
"e0fa68c7718fffd33d81af415279d6ddb518f727")
(introduction
diff --git a/guix/channels.scm b/guix/channels.scm
index d84228c47e..8acf3d8742 100644
--- a/guix/channels.scm
+++ b/guix/channels.scm
@@ -122,13 +122,14 @@ (define-module (guix channels)
(define-record-type* <channel> channel make-channel
channel?
- (name channel-name)
- (url channel-url)
- (branch channel-branch (default "master"))
- (commit channel-commit (default #f))
- (introduction channel-introduction (default #f))
- (location channel-location
- (default (current-source-location)) (innate)))
+ (name channel-name)
+ (url channel-url)
+ (description channel-description (default #f)) ; string
+ (branch channel-branch (default "master"))
+ (commit channel-commit (default #f))
+ (introduction channel-introduction (default #f)) ; <channel-introduction>
+ (location channel-location
+ (default (current-source-location)) (innate)))
;; Channel introductions. A "channel introduction" provides a commit/signer
;; pair that specifies the first commit of the authentication process as well
--
2.38.1