(address . guix-patches@gnu.org)
Hi.
Not knowing better I added this to my operating-system form:
(groups (cons* (user-group
(name "jas")
(id "1000"))
%base-groups))
Running 'guix system reconfigure /etc/config.scm' worked fine, and upon
boot I was placed in group 30001. Any idea what happened? A warning
would have been nice.
If there had been an example in the manual I wouldn't have made the
mistake, so the attached patch improves this manual page:
/Simon
From 6b7464c2820fd5f8b570f78e6e79752bc47ceaf8 Mon Sep 17 00:00:00 2001
From: Simon Josefsson <simon@josefsson.org>
Date: Sun, 25 Dec 2022 22:04:42 +0100
Subject: [PATCH] doc: Improve user-group documentation.
* doc/guix.texi (User Accounts): Add user-group form and modify user-group
text and examples to use it.
---
doc/guix.texi | 20 +++++++++++++++-----
1 file changed, 15 insertions(+), 5 deletions(-)
Toggle diff (44 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index c5ae350a47..79475915ec 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -17165,8 +17165,8 @@ select the file system in an elegant fashion!
@cindex accounts
@cindex user accounts
User accounts and groups are entirely managed through the
-@code{operating-system} declaration. They are specified with the
-@code{user-account} and @code{user-group} forms:
+@code{operating-system} declaration. Users are specified with the
+@code{user-account} form:
@lisp
(user-account
@@ -17179,13 +17179,23 @@ User accounts and groups are entirely managed through the
(comment "Bob's sister"))
@end lisp
-Here's a user account that uses a different shell and a custom home
-directory (the default would be @file{"/home/bob"}):
+Groups are specified with the @code{user-group} form:
+
+@lisp
+(user-group
+ (name "bob")
+ (id 1000))
+ %base-groups))
+@end lisp
+
+Here's a user account that uses a different shell, a custom home
+directory (the default would be @file{"/home/bob"}) and uses the
+@code{bob} group instead of the traditional @code{users}.
@lisp
(user-account
(name "bob")
- (group "users")
+ (group "bob")
(comment "Alice's bro")
(shell (file-append zsh "/bin/zsh"))
(home-directory "/home/robert"))
--
2.38.1
-----BEGIN PGP SIGNATURE-----
iIoEARYIADIWIQSjzJyHC50xCrrUzy9RcisI/kdFogUCY6i+RBQcc2ltb25Aam9z
ZWZzc29uLm9yZwAKCRBRcisI/kdFohXxAQDYPDgAMEvLsdMSxT0r5hMX4Nk7nj2U
q+1627aWekc+yAEA1UD26fMqtbI5Hx2o9amWUd1Ng+Qb9LHLT1LimwKh6Qg=
=uu0Z
-----END PGP SIGNATURE-----