Hi Chris and thanks for looking into this,
Your proposal is very reasonable. I wasn't sure what to write but I've
given it a try in this replacement commit.
To be honest, I don't know why the AVR target isn't supported in the
standard GDB
build and I haven't been able to figure out how to list all supported
targets. I'm new to GDB in general so
I don't know if I'm the right person to do this writeup.
to package for Guix if it's of interest),
and the standard gdb gives me a bunch of error messages when I connect to
dwtk's remote gdbserver. I'm guessing this
incompatibility applies to all gdbservers implemented for AVR chips. I
haven't found much clarity of this in the GDB docs.
I presume this is the reason most distros package avr-gdb separately from
gdb like we're doing here.
I've taken the "synopsis" from Arch Linux
removed unsupported languages from the description, and just
mentioned that this is for the specific AVR microcontroller architecture.
Please let me know if that's good enough.
Thanks,
K.
On Thu, Nov 3, 2022 at 6:35 PM Christopher Baines <mail@cbaines.net> wrote:
Toggle quote (34 lines)
>
> Kristian Lein-Mathisen <kristianlein@gmail.com> writes:
>
> > I'd like to have avr-gdb available in GNU Guix.
> > I've used the Arch Linux PKGFILE as basis:
> >
> >
> https://github.com/archlinux/svntogit-community/blob/fa92f7b2008ec/trunk/PKGBUILD
>
> Hi Kristian,
>
> This seems OK to me, although I don't know what this package is for?
>
> Given this is inheriting from gdb, it'll have the same synopiss and
> description:
>
> synopsis: The GNU debugger
> description: GDB is the GNU debugger. With it, you can monitor what a
> program
> + is doing while it runs or what it was doing just before a crash. It
> allows
> + you to specify the runtime conditions, to define breakpoints, and to
> change
> + how the program is running to try to fix bugs. It can be used to debug
> + programs written in C, C++, Ada, Objective-C, Pascal and more.
>
> So, I think if there is something different about this avr-gdb, it would
> be good to specify a appropriate synopsis and description. Does that
> make sense?
>
> Thanks,
>
> Chris
>
From 5a78944fbb6f5768286ccbeaa1168397096a7063 Mon Sep 17 00:00:00 2001
* gnu/packages/gdb.scm (avr-gdb): New variable.
---
gnu/packages/gdb.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
Toggle diff (33 lines)
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index 7d8416c7c5..fd0bc80e44 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -171,3 +171,24 @@ (define-public gdb-minimal
(name "gdb-minimal")
(inputs (fold alist-delete (package-inputs gdb)
'("libxml2" "ncurses" "python-wrapper" "source-highlight")))))
+
+(define-public avr-gdb
+ (package/inherit gdb-12
+ (name "avr-gdb")
+ (arguments
+ `(#:configure-flags
+ (list "--target=avr"
+ "--disable-nls"
+ "--enable-languages=c,c++"
+ "--with-system-readline"
+ "--enable-source-highlight")
+ ,@(package-arguments gdb-12)))
+ (synopsis "The GNU Debugger for AVR")
+ (description
+ "GDB is the GNU debugger. With it, you can monitor what a program is
+doing while it runs or what it was doing just before a crash. It allows you
+to specify the runtime conditions, to define breakpoints, and to change how
+the program is running to try to fix bugs.
+
+This variant of GDB can be used to debug programs written for the AVR
+microcontroller architecture.")))
base-commit: 807bfe55dc382b88ab0fdade6886dfa2b15487ee
--
2.38.0