(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
* gnu/packages/music.scm (synthpod): New variable.
---
gnu/packages/music.scm | 45 +++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)
Toggle diff (63 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 6b37c79..6ff2c99 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -173,6 +173,7 @@
#:use-module (gnu packages sqlite)
#:use-module (gnu packages stb)
#:use-module (gnu packages tcl)
+ #:use-module (gnu packages terminals)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tex)
#:use-module (gnu packages time)
@@ -3456,6 +3457,50 @@ analogue-like user interface.")
socket or command line.")
(license license:gpl3+))))
+(define-public synthpod
+ (package
+ (name "synthpod")
+ (version "0.1.6505")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.open-music-kontrollers.ch/lv2/synthpod")
+ ;; Version is not tagged but mentioned in VERSION file.
+ (commit "8273142cd702583cb3662fbe0e2fd5d4075ee703")))
+ (sha256
+ (base32
+ "120qsd090pwkc21g9a5mm0pjb0rqn1iy4rs5lx3fs0qf3wa7k6ri"))))
+ (build-system meson-build-system)
+ ;; Fontconfig error: No writable cache directories
+ (arguments (list #:tests? #f))
+ (inputs (list alsa-lib
+ cairo
+ eudev
+ freetype
+ fontconfig
+ glew
+ glu
+ jack-1
+ libevdev
+ libinput
+ libvterm
+ lilv
+ lv2
+ pixman
+ sratom
+ xcb-util
+ xcb-util-wm
+ xcb-util-xrm
+ zita-alsa-pcmi))
+ (native-inputs (list ;lv2lint ; needed for tests
+ pkg-config))
+ (home-page "https://open-music-kontrollers.ch/lv2/synthpod/")
+ (synopsis "Nonlinear LV2 plugin container")
+ (description
+ "Synthpod is an LV2 host. It can be run as a standalone app and be used
+as a tool for live performances or general audio and event filtering.")
+ (license (list license:artistic2.0 license:gpl3+))))
+
(define-public curseradio
(let ((commit "1bd4bd0faeec675e0647bac9a100b526cba19f8d")
(revision "1"))
--
libgit2 1.4.3