Am Sonntag, dem 02.10.2022 um 20:30 -0500 schrieb jgart:
Toggle quote (20 lines)
> * gnu/packages/emacs-xyz.scm (emacs-meme): New variable.
> ---
> gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
> 1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 5049824bce..72a9e52043 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -552,6 +552,30 @@ (define-public emacs-telephone-line
> configuration language which makes it trivial to write your own
> themes.")
> (license license:gpl3+))))
>
> +(define-public emacs-meme
> + (let ((commit "0a0ca8f6babaca3fea94f308f8d58f5186eba920")
> + (revision "0"))
> + (package
> + (name "emacs-meme")
> + (version (git-version "20220125" revision commit))
We don't do melpa versions. Since this one seems to be missing any
version info whatsoever, use "0".
Toggle quote (19 lines)
> + (source
> + (origin
> + (method git-fetch)
> + (uri
> + (git-reference
> + (url "https://github.com/larsmagne/meme")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> "0c30qx0dmd9hym7m2kvjw39vq6b8n51hwhdks48sb7hsb069l039"))))
> + (build-system emacs-build-system)
> + (propagated-inputs
> + (list emacs-imgur-el))
> + (home-page "https://github.com/larsmagne/meme")
> + (synopsis "Emacs meme generator")
> + (description "@code{emacs-meme} provides a meme generator for
> Emacs.")
> + (license license:gpl2+))))
Note that this package asks you to install non-free fonts. In general,
the customizability of both this and imgur.el is too low to really call
it an emacs package imho (and the way emacs-meme handles fonts is not
up to par with what emacs faces can do). I spare you a full code
review, but rest assured that both packages should undergo some more
revisions before distro packaging.
Cheers