(address . guix-patches@gnu.org)
This makes it so that zuo follows our packaging guidelines on version numbers
and gives meaning to the home-page.
* gnu/packages/racket.scm (zuo)[version]: Use git-version.
[source]: Use “https://github.com/racket/zuo”as URL.
Adapt patches accordingly.
[arguments]: Drop phases.
---
gnu/packages/racket.scm | 30 ++++++++++++++----------------
1 file changed, 14 insertions(+), 16 deletions(-)
Toggle diff (49 lines)
diff --git a/gnu/packages/racket.scm b/gnu/packages/racket.scm
index 10f93a1362..e3a9360a75 100644
--- a/gnu/packages/racket.scm
+++ b/gnu/packages/racket.scm
@@ -232,28 +232,26 @@ (define %racket-origin
(define-public zuo
- (let ((revision #f))
+ (let ((revision "1")
+ (commit "dcde608b20cf0d71e34300e21cbeeb0509f391a3"))
(package
(name "zuo")
- (version (string-append %zuo-version
- "-racket"
- %racket-version
- (if revision "-guix" "")
- (or revision "")))
- (source %racket-origin)
+ (version (git-version "1.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/racket/zuo")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "094jhhi5672qyq7ynrd2fzxc08rrcgs58pzrfn1dyw8rdrfkrdgg"))
+ (patches (search-patches "racket-zuo-bin-sh.patch"))
+ (patch-flags '("-p4"))))
(outputs '("out" "debug"))
(build-system gnu-build-system)
(arguments
- (list
- #:out-of-source? #t
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'chdir
- (lambda args
- (chdir "racket/src/zuo"))))))
+ (list #:out-of-source? #t))
(home-page "https://github.com/racket/zuo")
- ;; ^ This is downstream of https://github.com/racket/racket,
- ;; but it's designed to be a friendly landing place
(synopsis "Tiny Racket for build scripts")
(description "Zuo is a tiny Racket with primitives for dealing
with files and running processes. It comes with a @command{make}-like
--
2.37.2