(address . guix-patches@gnu.org)(name . Nguy?n Gia Phong)(address . mcsinyx@disroot.org)
While file is an optional dependency, without it
file type determination and opening does not work out of the box.
---
gnu/packages/disk.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)
Toggle diff (38 lines)
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 47b15e588f79..58bd3db3812c 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
;;; Copyright © 2014, 2022 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Nguy?n Gia Phong <mcsinyx@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -800,7 +801,7 @@ (define-public ranger
"0lfjrpv3z4h0knd3v94fijrw2zjba51mrp3mjqx2c98wr428l26f"))))
(build-system python-build-system)
(inputs
- (list w3m))
+ (list file w3m))
(native-inputs
(list which
;; For tests.
@@ -815,11 +816,13 @@ (define-public ranger
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(ranger (string-append out "/bin/ranger"))
+ (file (assoc-ref inputs "file"))
(w3m (assoc-ref inputs "w3m"))
(w3mimgdisplay (string-append w3m
"/libexec/w3m/w3mimgdisplay")))
(wrap-program ranger
- `("W3MIMGDISPLAY_PATH" ":" prefix (,w3mimgdisplay)))
+ `("W3MIMGDISPLAY_PATH" ":" prefix (,w3mimgdisplay))
+ `("PATH" ":" prefix ,(list (string-append file "/bin"))))
#t)))
(replace 'check
;; The default check phase simply prints 'Ran 0 tests in 0.000s'.
--
2.37.0