Hi jgart,
jgart <jgart@dismail.de> writes:
Toggle quote (34 lines)
> * gnu/packages/python-xyz.scm (python-pyinjector): New variable.
> ---
> gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
> 1 file changed, 20 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 5b3a742cb7..453080a4b7 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -28981,6 +28981,26 @@ (define-public pudb
> keyboard-friendly package.")
> (license license:expat)))
>
> +(define-public python-pyinjector
> + (package
> + (name "python-pyinjector")
> + (version "1.0.6")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (pypi-uri "pyinjector" version ".zip"))
> + (sha256
> + (base32 "126n70qmrlqd25xmxwaf800abfm1k250zx01kx3dha2p6pk3vx89"))))
> + (build-system python-build-system)
> + (native-inputs (list unzip))
> + (home-page "https://github.com/kmaork/pyinjector")
> + (synopsis
> + "A tool/library allowing dynamic library injection into running processes")
> + (description
> + "This package provides a tool/library allowing dynamic library injection into
> +running processes")
> + (license license:expat)))
> +
Please run this through 'guix lint', and fix any problems reported (the
synopsis will be flagged, at least). Your description should end with a
period (i.e., be a complete sentence).
I assume the test suite is not run; you may have to fetch from git to do
so, but there is a test suite:
Thanks,
Maxim