(address . guix-patches@gnu.org)(name . Stefan Reichör)(address . stefan@xsteve.at)
* gnu/packages/web.scm (servefile): New variable.
---
gnu/packages/web.scm | 23 ++++++++++++++++++++++-
1 file changed, 22 insertions(+), 1 deletion(-)
Toggle diff (43 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index ee74a4385d..9df55d21cc 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -47,7 +47,7 @@
;;; Copyright © 2020, 2021 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@posteo.ro>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
-;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2021, 2022 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 la snesne <lasnesne@lagunposprasihopre.org>
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
@@ -5000,6 +5000,27 @@ can easily be invoked on a single file. Your partner can access the file with
tools they trust (e.g. wget).")
(license license:gpl2+)))
+(define-public servefile
+ (package
+ (name "servefile")
+ (version "0.5.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "servefile" version))
+ (sha256
+ (base32
+ "1ywi9yzc2l24nxfb2mvmkha7qfaapjvqchd6rhjbc54ijwrdq9m1"))))
+ (build-system python-build-system)
+ (inputs (list python-pyopenssl))
+ (arguments
+ '(#:tests? #f)) ; tests fail
+ (home-page "https://github.com/sebageek/servefile")
+ (synopsis "Serve or receive files from shell via a small HTTP server")
+ (description "Serve files from shell via a small HTTP server. It
+also supports uploads, SSL, HTTP basic auth and directory listings.")
+ (license license:gpl3+)))
+
(define netsurf-buildsystem
(package
(name "netsurf-buildsystem")
--
2.25.1