(address . guix-patches@gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
Hi Guix,
The lint command reports problems that I don't know how and if I have to fix:
```
[…]/gnu/packages/gnunet.scm:268:4: gnunet@0.15.3: label 'gnutls' does not match package name 'gnutls-dane'
[…]/gnu/packages/gnunet.scm:268:4: gnunet@0.15.3: label 'libidn' does not match package name 'libidn2'
[…]/gnu/packages/gnunet.scm:268:4: gnunet@0.15.3: label 'libjpeg' does not match package name 'libjpeg-turbo'
[…]/gnu/packages/gnunet.scm:360:14: gnunet@0.15.3: permanent redirect from https://gnunet.org/to https://www.gnunet.org/en/
```
Any help welcome!
Tanguy
* gnu/packages/gnunet.scm (gnunet): Update to 0.15.3.
[arguments] Disable failing tests.
---
gnu/packages/gnunet.scm | 21 +++++++++++++++++----
1 file changed, 17 insertions(+), 4 deletions(-)
Toggle diff (60 lines)
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 1c09c9047b..34c6efddcb 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -254,7 +254,7 @@ (define-public gnurl
(define-public gnunet
(package
(name "gnunet")
- (version "0.13.1")
+ (version "0.15.3")
(source
(origin
(method url-fetch)
@@ -262,7 +262,7 @@ (define-public gnunet
".tar.gz"))
(sha256
(base32
- "15jnca5zxng7r6m3qzq9lr73xxq0v6mvcp0lny3zrlkz5s2nmmq3"))))
+ "1iafi1rzx62lf26awmwk17ih3y7kyhr7mrqc4am8w1qyyjl6j9nn"))))
(build-system gnu-build-system)
(inputs
`(("bluez" ,bluez)
@@ -301,6 +301,8 @@ (define-public gnunet
(("test_transport_api_manipulation_cfg\\$\\(EXEEXT\\) \\\\\n") "")
(("test_transport_api_udp_nat\\$\\(EXEEXT\\) \\\\\n") "")
(("test_transport_blacklisting_multiple_plugins\\$\\(EXEEXT\\) \\\\\n") ""))
+ (substitute* "src/cadet/Makefile"
+ (("test_cadet_2_speed_reliable\\$\\(EXEEXT\\) \\\\\n") ""))
(substitute* "src/testbed/Makefile"
(("test_testbed_api_2peers_1controller\\$\\(EXEEXT\\) \\\\\n") "")
(("test_testbed_api_statistics\\$\\(EXEEXT\\) \\\\\n") "")
@@ -308,13 +310,24 @@ (define-public gnunet
(("test_testbed_api_test_timeout\\$\\(EXEEXT\\) \\\\\n") "")
(("test_testbed_api_topology\\$\\(EXEEXT\\) \\\\\n") "")
(("test_testbed_api_topology_clique\\$\\(EXEEXT\\) \\\\\n") ""))
+ (substitute* "src/testing/Makefile"
+ (("test_testing_api_cmd_netjail\\$\\(EXEEXT\\) \\\\\n") "")
+ (("test_testing_peerstartup\\$\\(EXEEXT\\) \\\\\n") "")
+ (("test_testing_peerstartup2\\$\\(EXEEXT\\) \\\\\n") ""))
(substitute* "src/topology/Makefile"
(("^check_PROGRAMS.*") "\n")
(("test_gnunet_daemon_topology\\$\\(EXEEXT\\)\n") ""))
(substitute* "src/namestore/Makefile"
- (("\\$\\(am__append_2\\)") ""))
+ (("\\$\\(am__append_2\\)") "")
+ ((" test_namestore_lookup\\.sh ") " "))
+ (substitute* "src/fs/Makefile"
+ (("test_fs_search_with_and\\$\\(EXEEXT\\) \\\\\n") ""))
(substitute* "src/gns/Makefile"
- (("\\$\\(am__append_4\\)") ""))
+ (("\\$\\(am__append_4\\)") "")
+ (("test_gns_caa_lookup.sh test_gns_mx_lookup.sh") "test_gns_caa_lookup.sh"))
+ (substitute* "src/revocation/Makefile"
+ (("^check_SCRIPTS.*") "")
+ ((" test_local_revocation.py\n") ""))
(substitute* "contrib/Makefile"
(("^check_PROGRAMS.*") "\n"))
;; 'test' from coreutils doesn't behave as the test expects.
--
2.34.0