(address . guix-patches@gnu.org)(name . Ian Ressa)(address . ian@eonn.xyz)
Adding python-posix-ipc to gnu/packages/python-xyz.scm
---
gnu/packages/python-xyz.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)
Toggle diff (49 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 46419e8ace..53d5588564 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -116,6 +116,7 @@
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
+;;; Copyright © 2022 Ian Ressa <ian@eonn.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28926,3 +28927,34 @@ (define-public python-types-dataclasses
"This packages provides a collection of library stubs for Python, with
static types.")
(license license:asl2.0)))
+
+(define-public python-posix-ipc
+ (package
+ (name "python-posix-ipc")
+ (version "1.0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "posix_ipc" version))
+ (sha256
+ (base32 "15wbxf67y17g04i3f3vjw9zjbvlvqqk9q1x0ya1y7apl5k7b3pbc"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:modules ((guix build python-build-system)
+ ((guix build gnu-build-system) #:prefix gnu:)
+ (guix build utils))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'support-cross-compilation
+ (lambda _
+ (substitute* "prober.py"
+ (("cc") ,(cc-for-target)))
+ #t)))))
+ (home-page "http://semanchuk.com/philip/posix_ipc/")
+ (synopsis
+ "POSIX IPC primitives (semaphores, shared memory and message
+queues) for Python")
+ (description
+ "The Python extension module posix_ipc gives Python access to
+POSIX inter-process semaphores, shared memory and message queues on systems
+that support the POSIX Realtime Extensions a.k.a. POSIX 1003.1b-1993.")
+ (license license:bsd-3)))
--
2.34.0