[PATCH] gnu: mono: Update to 4.8.1.0.

  • Done
  • quality assurance status badge
Details
3 participants
  • Andy Tai
  • Leo Famulari
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Andy Tai
Severity
normal
A
A
Andy Tai wrote on 18 Dec 2021 02:20
(address . guix-patches@gnu.org)
CAJsg1E8XBCDa+rAZKg5Zfhi3msBMxU5uKbKh2njbC+06NuH1iw@mail.gmail.com

From bad68e7f6396169007ae707a029c0779f627f306 Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Fri, 17 Dec 2021 17:14:59 -0800
Subject: [PATCH] gnu: mono: Update to 4.8.1.0.
To: guix-patches@gnu.org

gnu/packages/mono.scm (mono): Update to 4.8.1.0.
---
gnu/packages/mono.scm | 12 +++++++++---
1 file changed, 9 insertions(+), 3 deletions(-)

Toggle diff (57 lines)
diff --git a/gnu/packages/mono.scm b/gnu/packages/mono.scm
index 6a7afbafbf..8dad3c547a 100644
--- a/gnu/packages/mono.scm
+++ b/gnu/packages/mono.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2021 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -19,6 +20,9 @@
(define-module (gnu packages mono)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix utils)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages cmake)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
@@ -33,12 +37,13 @@ (define-module (gnu packages mono)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu))
(define-public mono
(package
(name "mono")
- (version "4.4.1.0")
+ (version "4.8.1.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -47,11 +52,12 @@ (define-public mono
".tar.bz2"))
(sha256
(base32
- "0jibyvyv2jy8dq5ij0j00iq3v74r0y90dcjc3dkspcfbnn37cphn"))
+ "1vyvp2g28ihcgxgxr8nhzyzdmzicsh5djzk8dk1hj5p5f2k3ijqq"))
(patches (search-patches "mono-mdoc-timestamping.patch"))))
(build-system gnu-build-system)
(native-inputs
- `(("gettext" ,gettext-minimal)
+ `(("cmake" ,cmake-minimal)
+ ("gettext" ,gettext-minimal)
("glib" ,glib)
("libxslt" ,libxslt)
("perl" ,perl)

base-commit: b4ee524e5adb2153a0de607a32100a8db2b12585
prerequisite-patch-id: 0bc0b33477cdab26d37501579ca950e4cbf6e050
--
2.34.0
L
L
Leo Famulari wrote on 18 Dec 2021 21:00
(name . Andy Tai)(address . atai@atai.org)(address . 52592@debbugs.gnu.org)
Yb496+UdXbH3wxPt@jasmine.lan
On Fri, Dec 17, 2021 at 05:20:29PM -0800, Andy Tai wrote:
Toggle quote (10 lines)
>

> From bad68e7f6396169007ae707a029c0779f627f306 Mon Sep 17 00:00:00 2001
> From: Andy Tai <atai@atai.org>
> Date: Fri, 17 Dec 2021 17:14:59 -0800
> Subject: [PATCH] gnu: mono: Update to 4.8.1.0.
> To: guix-patches@gnu.org
>
> gnu/packages/mono.scm (mono): Update to 4.8.1.0.

Thanks for the patch!

Toggle quote (5 lines)
> (native-inputs
> - `(("gettext" ,gettext-minimal)
> + `(("cmake" ,cmake-minimal)
> + ("gettext" ,gettext-minimal)

Just checking, is the addition of cmake-minimal intentional? It wasn't
mentioned in the commit message.
A
A
Andy Tai wrote on 18 Dec 2021 22:25
(name . Leo Famulari)(address . leo@famulari.name)(address . 52592@debbugs.gnu.org)
CAJsg1E-=qTAv9fDe=QkX4UaYRHyxQB2BS+r8x-0TtOtD76LUJw@mail.gmail.com
Yes, it is intentional. The build process needs cmake. I am not
sure how that is to be stated in the commit message.

On Sat, Dec 18, 2021 at 12:00 PM Leo Famulari <leo@famulari.name> wrote:
Toggle quote (24 lines)
>
> On Fri, Dec 17, 2021 at 05:20:29PM -0800, Andy Tai wrote:
> >
>
> > From bad68e7f6396169007ae707a029c0779f627f306 Mon Sep 17 00:00:00 2001
> > From: Andy Tai <atai@atai.org>
> > Date: Fri, 17 Dec 2021 17:14:59 -0800
> > Subject: [PATCH] gnu: mono: Update to 4.8.1.0.
> > To: guix-patches@gnu.org
> >
> > gnu/packages/mono.scm (mono): Update to 4.8.1.0.
>
> Thanks for the patch!
>
> > (native-inputs
> > - `(("gettext" ,gettext-minimal)
> > + `(("cmake" ,cmake-minimal)
> > + ("gettext" ,gettext-minimal)
>
> Just checking, is the addition of cmake-minimal intentional? It wasn't
> mentioned in the commit message.



--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat: andytai1010
Year 2021 ??110?
????????????
????????????
L
L
Leo Famulari wrote on 19 Dec 2021 00:45
(name . Andy Tai)(address . atai@atai.org)(address . 52592@debbugs.gnu.org)
Yb5yoWdCGC6OWnW8@jasmine.lan
On Sat, Dec 18, 2021 at 01:25:48PM -0800, Andy Tai wrote:
Toggle quote (3 lines)
> Yes, it is intentional. The build process needs cmake. I am not
> sure how that is to be stated in the commit message.

Okay. The commit message would look like this:

------
gnu: mono: Update to 4.8.1.0.

gnu/packages/mono.scm (mono): Update to 4.8.1.0.
[native-inputs]: Add cmake-minimal
------

I amended the commit message, applied the patch on the 'master' branch
[0], and then built the package. However, it fails to build, like this:

------
Assembling 'event-il.il' , no listing file, to exe --> 'event-il.exe'

Operation completed successfully
MONO_PATH=/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mcs/class/lib/net_4_x ../../runtime/mono-wrapper /tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mcs/class/lib/net_4_x/ilasm.exe -out:module-cctor.exe module-cctor.il
Assembling 'module-cctor.il' , no listing file, to exe --> 'module-cctor.exe'

Operation completed successfully
make[5]: *** No rule to make target 'TestingReferenceAssembly.dll', needed by 'runtest-managed'. Stop.
make[5]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono/tests'
make[4]: *** [Makefile:1874: testjit] Error 2
make[4]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono/tests'
make[3]: *** [Makefile:1584: check-am] Error 2
make[3]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono/tests'
make[2]: *** [Makefile:1436: check-recursive] Error 1
make[2]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono/tests'
make[1]: *** [Makefile:445: check-recursive] Error 1
make[1]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono'
make: *** [Makefile:525: check-recursive] Error 1

Test suite failed, dumping logs.
error: in phase 'check': uncaught exception:
%exception #<&invoke-error program: "make" arguments: ("check" "PLATFORM_DISABLED_TESTS= appdomain-unload.exe delegate2.exe finally_guard.exe remoting4.exe") exit-status: 2 term-signal: #f stop-signal: #f>
phase `check' failed after 215.7 seconds
command "make" "check" "PLATFORM_DISABLED_TESTS= appdomain-unload.exe delegate2.exe finally_guard.exe remoting4.exe" failed with status 2
builder for `/gnu/store/h272hagn74q18q4djhkar1fg9ksqnxp3-mono-4.8.1.0.drv' failed with exit code 1
build of /gnu/store/h272hagn74q18q4djhkar1fg9ksqnxp3-mono-4.8.1.0.drv failed
------

Any ideas? Does it work for you?

[0] On commit f6e79ef108a206a2fb3db550d76de760d581f8a8
A
A
Andy Tai wrote on 19 Dec 2021 01:25
(name . Leo Famulari)(address . leo@famulari.name)(address . 52592@debbugs.gnu.org)
CAJsg1E-wRspx86sNJVTWGwDQqOqC7LqTt6HZNeTgstT5oCqz9A@mail.gmail.com
It did pass for me. I am not sure why the behavior can be different.

On Sat, Dec 18, 2021 at 3:45 PM Leo Famulari <leo@famulari.name> wrote:
Toggle quote (52 lines)
>
> On Sat, Dec 18, 2021 at 01:25:48PM -0800, Andy Tai wrote:
> > Yes, it is intentional. The build process needs cmake. I am not
> > sure how that is to be stated in the commit message.
>
> Okay. The commit message would look like this:
>
> ------
> gnu: mono: Update to 4.8.1.0.
>
> gnu/packages/mono.scm (mono): Update to 4.8.1.0.
> [native-inputs]: Add cmake-minimal
> ------
>
> I amended the commit message, applied the patch on the 'master' branch
> [0], and then built the package. However, it fails to build, like this:
>
> ------
> Assembling 'event-il.il' , no listing file, to exe --> 'event-il.exe'
>
> Operation completed successfully
> MONO_PATH=/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mcs/class/lib/net_4_x ../../runtime/mono-wrapper /tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mcs/class/lib/net_4_x/ilasm.exe -out:module-cctor.exe module-cctor.il
> Assembling 'module-cctor.il' , no listing file, to exe --> 'module-cctor.exe'
>
> Operation completed successfully
> make[5]: *** No rule to make target 'TestingReferenceAssembly.dll', needed by 'runtest-managed'. Stop.
> make[5]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono/tests'
> make[4]: *** [Makefile:1874: testjit] Error 2
> make[4]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono/tests'
> make[3]: *** [Makefile:1584: check-am] Error 2
> make[3]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono/tests'
> make[2]: *** [Makefile:1436: check-recursive] Error 1
> make[2]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono/tests'
> make[1]: *** [Makefile:445: check-recursive] Error 1
> make[1]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono'
> make: *** [Makefile:525: check-recursive] Error 1
>
> Test suite failed, dumping logs.
> error: in phase 'check': uncaught exception:
> %exception #<&invoke-error program: "make" arguments: ("check" "PLATFORM_DISABLED_TESTS= appdomain-unload.exe delegate2.exe finally_guard.exe remoting4.exe") exit-status: 2 term-signal: #f stop-signal: #f>
> phase `check' failed after 215.7 seconds
> command "make" "check" "PLATFORM_DISABLED_TESTS= appdomain-unload.exe delegate2.exe finally_guard.exe remoting4.exe" failed with status 2
> builder for `/gnu/store/h272hagn74q18q4djhkar1fg9ksqnxp3-mono-4.8.1.0.drv' failed with exit code 1
> build of /gnu/store/h272hagn74q18q4djhkar1fg9ksqnxp3-mono-4.8.1.0.drv failed
> ------
>
> Any ideas? Does it work for you?
>
> [0] On commit f6e79ef108a206a2fb3db550d76de760d581f8a8



--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat: andytai1010
Year 2021 ??110?
????????????
????????????
A
A
Andy Tai wrote on 19 Dec 2021 02:28
(name . Leo Famulari)(address . leo@famulari.name)(address . 52592@debbugs.gnu.org)
CAJsg1E8MM6H9jKFAYEAaONnm2-uXE9+r=VzQGaQmNXHT5AwDXQ@mail.gmail.com
In any case, if you want to revert it, go ahead. I am now trying to
upgrade to Mono 6.

On Sat, Dec 18, 2021 at 4:25 PM Andy Tai <atai@atai.org> wrote:
Toggle quote (64 lines)
>
> It did pass for me. I am not sure why the behavior can be different.
>
> On Sat, Dec 18, 2021 at 3:45 PM Leo Famulari <leo@famulari.name> wrote:
> >
> > On Sat, Dec 18, 2021 at 01:25:48PM -0800, Andy Tai wrote:
> > > Yes, it is intentional. The build process needs cmake. I am not
> > > sure how that is to be stated in the commit message.
> >
> > Okay. The commit message would look like this:
> >
> > ------
> > gnu: mono: Update to 4.8.1.0.
> >
> > gnu/packages/mono.scm (mono): Update to 4.8.1.0.
> > [native-inputs]: Add cmake-minimal
> > ------
> >
> > I amended the commit message, applied the patch on the 'master' branch
> > [0], and then built the package. However, it fails to build, like this:
> >
> > ------
> > Assembling 'event-il.il' , no listing file, to exe --> 'event-il.exe'
> >
> > Operation completed successfully
> > MONO_PATH=/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mcs/class/lib/net_4_x ../../runtime/mono-wrapper /tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mcs/class/lib/net_4_x/ilasm.exe -out:module-cctor.exe module-cctor.il
> > Assembling 'module-cctor.il' , no listing file, to exe --> 'module-cctor.exe'
> >
> > Operation completed successfully
> > make[5]: *** No rule to make target 'TestingReferenceAssembly.dll', needed by 'runtest-managed'. Stop.
> > make[5]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono/tests'
> > make[4]: *** [Makefile:1874: testjit] Error 2
> > make[4]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono/tests'
> > make[3]: *** [Makefile:1584: check-am] Error 2
> > make[3]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono/tests'
> > make[2]: *** [Makefile:1436: check-recursive] Error 1
> > make[2]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono/tests'
> > make[1]: *** [Makefile:445: check-recursive] Error 1
> > make[1]: Leaving directory '/tmp/guix-build-mono-4.8.1.0.drv-0/mono-4.8.1/mono'
> > make: *** [Makefile:525: check-recursive] Error 1
> >
> > Test suite failed, dumping logs.
> > error: in phase 'check': uncaught exception:
> > %exception #<&invoke-error program: "make" arguments: ("check" "PLATFORM_DISABLED_TESTS= appdomain-unload.exe delegate2.exe finally_guard.exe remoting4.exe") exit-status: 2 term-signal: #f stop-signal: #f>
> > phase `check' failed after 215.7 seconds
> > command "make" "check" "PLATFORM_DISABLED_TESTS= appdomain-unload.exe delegate2.exe finally_guard.exe remoting4.exe" failed with status 2
> > builder for `/gnu/store/h272hagn74q18q4djhkar1fg9ksqnxp3-mono-4.8.1.0.drv' failed with exit code 1
> > build of /gnu/store/h272hagn74q18q4djhkar1fg9ksqnxp3-mono-4.8.1.0.drv failed
> > ------
> >
> > Any ideas? Does it work for you?
> >
> > [0] On commit f6e79ef108a206a2fb3db550d76de760d581f8a8
>
>
>
> --
> Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat: andytai1010
> Year 2021 ??110?
> ????????????
> ????????????



--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat: andytai1010
Year 2021 ??110?
????????????
????????????
L
L
Leo Famulari wrote on 20 Dec 2021 18:56
(name . Andy Tai)(address . atai@atai.org)(address . 52592@debbugs.gnu.org)
YcDD4MBiUjCbBfJR@jasmine.lan
On Sat, Dec 18, 2021 at 05:28:37PM -0800, Andy Tai wrote:
Toggle quote (3 lines)
> In any case, if you want to revert it, go ahead. I am now trying to
> upgrade to Mono 6.

No need to revert, because I had only applied it locally. I hadn't yet
pushed to Savannah. Maybe it's a non-deterministic build failure. I'll
try building on one core and similar things.
M
M
Maxim Cournoyer wrote on 14 Sep 2022 15:19
control message for bug #52592
(address . control@debbugs.gnu.org)
87zgf214c8.fsf@gmail.com
tags 52592 wontfix
close 52592
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 52592@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 52592
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch