(address . guix-patches@gnu.org)(name . Olivier Dion)(address . olivier.dion@polymtl.ca)
* gnu/packages/linux.scm (babeltrace): New variable.
Signed-off-by: Olivier Dion <olivier.dion@polymtl.ca>
---
gnu/packages/linux.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)
Toggle diff (55 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9bb90e599e..dcfea9cc6c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -131,6 +131,7 @@
#:use-module (gnu packages sdl)
#:use-module (gnu packages serialization)
#:use-module (gnu packages slang)
+ #:use-module (gnu packages sphinx)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tls)
@@ -8051,6 +8052,40 @@ enable and disable specific instrumentation points, and writes event records
to ring buffers shared with a consumer daemon.")
(license license:lgpl2.1+)))
+(define-public babeltrace
+ (package
+ (name "babeltrace")
+ (version "2.0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.efficios.com/files/babeltrace/babeltrace2-"
+ version ".tar.bz2"))
+ (sha256
+ (base32 "1804pyq7fz6rkcz4r1abkkn0pfnss13m6fd8if32s42l4lajadm5"))))
+
+ (build-system gnu-build-system)
+
+ (propagated-inputs
+ `(("elfutils" ,elfutils)))
+
+ (native-inputs
+ `(("asciidoc" ,asciidoc)
+ ("bison" ,bison)
+ ("flex" ,flex)
+ ("glib" ,glib)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-3)
+ ("python-sphinx" ,python-sphinx)
+ ("xmltoman" ,xmltoman)))
+
+ (home-page "https://babeltrace.org/")
+ (synopsis "Babeltrace /?bæb?ltre?s/ is an open-source trace manipulation toolkit.")
+ (description "Babeltrace 2 is the reference parser implementation of the
+Common Trace Format (CTF), a versatile trace format produced by various
+tracers and tools such as LTTng and barectf. The Babeltrace 2 library and its
+Python bindings can read and write CTF traces.")
+ (license license:expat)))
+
(define-public kexec-tools
(package
(name "kexec-tools")
--
2.33.0