(address . bug-guix@gnu.org)
Hi,
On commit 100281dd200d0a59958fb17dc6de75d3913e2b7a, the build for
texlive-latex-graphics sometimes fails and sometimes succeeds. To
reproduce the issue, just try "guix build texlive-latex-graphics" or
"guix build --check texlive-latex-graphics" a few times. I used this
cumbersome one-liner to try it a bunch:
while :; do if ./pre-inst-env guix build --cores=1 --check texlive-latex-graphics; then echo SUCCESS; else echo FAIL; fi; done 2>&1 | tee /tmp/out
Then you can summarize the results with another cumbersome one-liner
like this:
cat /tmp/out | grep -e ^FAIL -e ^SUCCESS | sort | uniq -c | awk '{arr[$2] = $1; arr["TOTAL"] += $1} END {for (i in arr) printf("%5d (%6.2f%%): %s\n", arr[i], 100*arr[i]/arr["TOTAL"], i)}'
This failure happens on powerpc64le-linux and x86_64-linux. It might
happen on other architectures; I didn't test them. In my testing, it
happened about 18% of the time on powerpc64le-linux, and about 1% of the
time on x86_64-linux.
Here is the error from the powerpc64le-linux case. Except for the store
paths, the error is identical to the x86_64-linux case:
Toggle snippet (30 lines)
Generating file(s) dvipdf.def dvipsone.def dviwin.def emtex.def pctexps.def pctex32.def pctexhp.def pctexwin.def truetex.def tcidvi.def dvipsnam.def
Processing file drivers.dtx (dvipdf,color1,psrulesZ) -> dvipdf.def
(tiffrules,dvipsone,color1,dosrules,psrules) -> dvipsone.def
(dviwin,nops) -> dviwin.def
(emtex,dosrules,nops) -> emtex.def
(pctexps,color3,colorfix) -> pctexps.def
(pctex32,color1) -> pctex32.def
(pctexhp,nops) -> pctexhp.def
(pctexwin,nops) -> pctexwin.def
(truetex,color4,nops) -> truetex.def
(tcidvi,color4,nops) -> tcidvi.def
(dvipsnames) -> dvipsnam.def
Lines processed: 1701
Comments removed: 776
Comments passed: 9
Codelines passed: 757
)
warning (pdf backend): no pages of output.
Transcript written on graphics-drivers.log.
realloc(): invalid next size
command "luatex" "-interaction=nonstopmode" "-output-directory=build" "&luatex" "graphics-drivers.ins" failed with signal 6
builder for `/gnu/store/r6xcixwj7y2336lg68clqck74prckzbd-texlive-latex-graphics-51265.drv' failed with exit code 1
build of /gnu/store/r6xcixwj7y2336lg68clqck74prckzbd-texlive-latex-graphics-51265.drv failed
View build log at '/var/log/guix/drvs/r6/xcixwj7y2336lg68clqck74prckzbd-texlive-latex-graphics-51265.drv.bz2'.
guix build: error: build of `/gnu/store/r6xcixwj7y2336lg68clqck74prckzbd-texlive-latex-graphics-51265.drv' failed
FAIL
Signal 6 is SIGABRT on these systems; I'm not sure what the failure
means or what might be causing it, but I haven't dug into it much yet.
--
Chris
-----BEGIN PGP SIGNATURE-----
iQJJBAEBCAAzFiEEy/WXVcvn5+/vGD+x3UCaFdgiRp0FAmCgNtwVHGNtbWFydXNp
Y2hAZ21haWwuY29tAAoJEN1AmhXYIkadyTAQAI48MvN/mWRVyi97wUHU3rB+BuCl
I32nXN/Kv6A5eCNeg1o4Z3meis1srF3hOVMNZK1Ks85Od+SAfjQHmYpzSzZ8YkdE
W14EocW4ZDOyxN1Ap8CMv3UZBGadTZB8BCDC8FPCRpHYbYb02N/M630LWsKPncIP
6j8G3JH/ASXpB2xeqj7O0emB/GAQXF4aCwt05lOQLyTmmy1gQSN3WUB7jf4kSiFY
flr8VCqqaguveUwYRRPUmfGOtEM5bqGuD5JEKdqYKNov9auLlCiQRYKSBV8udOZE
Ofll4o3GBAyTD6oHTe4Uo6R3ZMOukzsJea1/E3mQ3+wPzMPNK9QVSIfM7IKJsnc5
A78LGoOKwtf7KiLX4R5jpVAMbR7+HKHLLwo5oJlXw1fKr5xH+loSKh6imu+9Lxzk
iMWDXeRhgHu5JhICdQZKKcnH6b/2hqRgnv34OLOJsxg/vSwOXF6u50ldrvE0O/CF
pUgPb4yHUvWlUUZSUO04mwDBerUse6wAq/hqt+W6TYDXJw11DBNuSvdVCP4gk607
CvYfysz/EAM/2PwUHZg27FHRP7LaaOgJvDyeJpGxuvGDWEih88uIltAEu5N55Ocg
ngOjEJtVMURHxu9imsMJaIROZaSOTu9au3GttVB3vv7mzuXNN5naOlP6hIlimYsJ
JdquULkAvRPI3FzB
=JvYq
-----END PGP SIGNATURE-----