(address . guix-patches@gnu.org)
* gnu/packages/guile.scm (guile-git): Update to 0.5.0.
[source]: Use ‘git-fetch’ instead of ‘url-fetch’.
[native-inputs]: Add autoconf, automake, and texinfo.
---
I used ‘git-fetch’ because it is more flexible than ‘url-fetch’, users
can for example use package transformations to easily use a desired
commit/branch. Because the distributed tarball includes files that are
generated by running ‘./configure’, users would then have to manually
add some native-inputs to make it build with a custom version of the
package (this has happened to me a few times).
gnu/packages/guile.scm | 15 +++++++++------
1 file changed, 9 insertions(+), 6 deletions(-)
Toggle diff (39 lines)
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 0dad390275..76741504c8 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -776,21 +776,24 @@ type system, elevating types to first-class status.")
(define-public guile-git
(package
(name "guile-git")
- (version "0.4.0")
+ (version "0.5.0")
(home-page "https://gitlab.com/guile-git/guile-git.git")
(source (origin
- (method url-fetch)
- (uri (string-append "https://gitlab.com/guile-git/guile-git/uploads/"
- "2600bb0dfdfb00bfbe46811dccad51d8/guile-git-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/guile-git/guile-git")
+ (commit (string-append "v" version))))
(sha256
(base32
- "1kxyg9x2aa1pg69cl48wysq0pbxvwfahy1xpl5ab6p8babhf7kic"))))
+ "1hqw3jy81cnsgybsbnfvwvhv1bajwq662hikkrr6dcgky6yspsxx"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags '("GUILE_AUTO_COMPILE=0"))) ; to prevent guild warnings
(native-inputs
`(("pkg-config" ,pkg-config)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("texinfo" ,texinfo)
("guile" ,guile-3.0)
("guile-bytestructures" ,guile-bytestructures)))
(inputs
base-commit: 82543e9649da2da9a5285ede4ec4f718fd740fcb
--
2.31.1