(address . bug-guix@gnu.org)
Hello Guixters,
I am trying to deploy a system on DigitalOcean droplet using `guix
deploy`. But I am facing the following issue :
$ guix deploy ynm-machine-declaration.scm
La (1) machine suivante sera déployée :
ynm
guix deploy: déploiement vers ynm...
;;; [2020/12/02 00:15:48.683027, 0] read_from_channel_port: [GSSH
ERROR] Error reading from the channel: #<unknown channel (freed)
7f3ca3ef80a0>
Then I decided to Ctrl-C the process.
Sometimes I did ssh to the target to see if I can see proof that things
were doing ok (for example if the infect script is created in the tmp
directory...). And I noticed I had to delete the ssh key of the target
on my laptop to ssh again...
ssh-keygen -f "/home/jeko/.ssh/known_hosts" -R "159.89.21.175"
Then, on the target machine guix seems to be installed. I am able to
run `guix pull`. But the packages I wanted to be globally installed
were missing.
On the laptop I deployed from:
$ guix --version
guix (GNU Guix) d848b6caab973f6191143360ca53787a19c5e6e4
Copyright © 2020 les auteurs de Guix
Licence GPLv3+ : GNU GPL version 3 ou ultérieure <
Ceci est un logiciel libre : vous êtes libre de le modifier et de le
redistribuer.
Il n'y a AUCUNE GARANTIE, dans les limites permises par la loi.
On the droplet after guix pull:
# guix --version
guix (GNU Guix) 04b83678653fda3c66e600e88f54f5108290ec1c
Copyright (C) 2020 the Guix authors
License GPLv3+: GNU GPL version 3 or later <
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
I have no clue how to provide more info (logs, traces, …) but I would
be very happy to do so if anyone can lead me a bit on that.
Cheers,
Jeko
(add-to-load-path (getcwd))
(use-modules (gnu)
(ynm-system-decalaration))
;; (machine
;; (operating-system %ynm-system-decalaration)
;; (environment managed-host-environment-type)
;; (configuration (machine-ssh-configuration
;; (host-name "yournextmeal.tech")
;; (host-key "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIGXArluyIh9+8Nooz9a7LoQV8ree1jpFLMvp7wPsgiMO root@yournextmeal.tech")
;; (system "x86_64-linux")
;; (user "root")
;; (identity "/home/jeko/.ssh/id_ed25519.pub")
;; (port 2222))))
(list
(machine
(operating-system %ynm-system-decalaration)
(environment digital-ocean-environment-type)
(configuration (digital-ocean-configuration
(region "fra1")
(size "s-1vcpu-1gb")
(ssh-key "/home/jeko/.ssh/id_rsa")
(tags (list "guix" "ynm"))
(enable-ipv6? #f)))))
(define-module (ynm-system-decalaration))
(use-modules (gnu)
(gnu services))
(use-service-modules ssh networking)
(use-package-modules screen ssh certs version-control)
(define-public %ynm-system-decalaration
(operating-system
(host-name "ynm")
(timezone "Europe/Paris")
(locale "fr_FR.utf8")
(packages (cons* screen git nss-certs %base-packages))
(bootloader (bootloader-configuration
(bootloader grub-bootloader)
(target "/dev/vda")))
(file-systems (cons (file-system
(mount-point "/")
(device "/dev/vda1")
(type "ext4"))
%base-file-systems))
(initrd-modules (append (list "virtio_scsi")
%base-initrd-modules))
(services
(append
(list
(service dhcp-client-service-type)
(service openssh-service-type
(openssh-configuration
(openssh openssh-sans-x)
(permit-root-login 'without-password)
(authorized-keys
`(("root" ,(local-file "/home/jeko/.ssh/id_rsa.pub"))))
(port-number 2222))))
(modify-services %base-services
(guix-service-type ynm-config =>
(guix-configuration (inherit ynm-config)
(authorized-keys
(append
(list (local-file "/etc/guix/signing-key.pub"))
%default-authorized-guix-keys)))))))))
%ynm-system-decalaration