(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
Hi all,
I packaged GPUtils (patch below) but I'm not sure about how to separate the
documentation (a large folder full of htmls) to a "doc" output, like other
packages have. I tried setting --htmldir configure-flag but it didn't change
anything, I also considered moving the docs to the "doc" output by hand in
an extra phase but I don't know if it's the best thing to do.
Ideas?
Thanks!
From 6baa681504c18d9768142937a1d014e59366bee3 Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Tue, 10 Nov 2020 20:30:14 +0100
Subject: [PATCH] gnu: Add gputils.
* gnu/packages/electronics.scm (gputils): New variable.
---
gnu/packages/electronics.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)
Toggle diff (28 lines)
diff --git a/gnu/packages/electronics.scm b/gnu/packages/electronics.scm
index d21ec61039..2b5fd25a15 100644
--- a/gnu/packages/electronics.scm
+++ b/gnu/packages/electronics.scm
@@ -276,3 +276,23 @@ format support.")
(description "PulseView is a Qt based logic analyzer, oscilloscope and MSO GUI
for sigrok.")
(license license:gpl3+)))
+
+
+(define-public gputils
+ (package
+ (name "gputils")
+ (version "1.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/gputils/gputils/"
+ version "/gputils-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1xfvmvb6zyzs5bqycbvmc6hyl2vp2pv22aaq5974vip4rriklhf7"))))
+ (build-system gnu-build-system)
+ (home-page "https://gputils.sourceforge.io/")
+ (synopsis "GNU PIC Utilities")
+ (description "GPUTILS is a collection of tools for the Microchip (TM) PIC
+microcontrollers. It includes gpasm, gplink, and gplib.")
+ (license license:gpl2+)))
--
2.28.0