(address . guix-patches@gnu.org)
* guix/scripts/upgrade.scm (%options): Add "do-not-upgrade" to list of
options inherited from guix package.
---
guix/scripts/upgrade.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
Toggle diff (22 lines)
diff --git a/guix/scripts/upgrade.scm b/guix/scripts/upgrade.scm
index 7f14a2fdbe..d2784669be 100644
--- a/guix/scripts/upgrade.scm
+++ b/guix/scripts/upgrade.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2020 Jakub K?dzio?ka <kuba@kadziolka.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -60,7 +61,7 @@ This is an alias for 'guix package -u'.\n"))
;; Preserve some of the 'guix package' options.
(append (filter (lambda (option)
(any (cut member <> (option-names option))
- '("profile" "dry-run" "verbosity")))
+ '("profile" "dry-run" "verbosity" "do-not-upgrade")))
%package-options)
%transformation-options
--
2.28.0