From 299cb02e12cc13dbdb762d6b4ea3ca791556dcaa Mon Sep 17 00:00:00 2001
* gnu/packages/shellutils.scm (z): New variable.
Signed-off-by: Collin J. Doering <collin@rekahsoft.ca>
---
gnu/packages/shellutils.scm | 45 +++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)
Toggle diff (70 lines)
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index f7542ea759..878620d8c0 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
+;;; Copyright © 2019 Collin J. Doering <collin@rekahsoft.ca>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,11 +34,55 @@
#:use-module (gnu packages ncurses)
#:use-module (gnu packages readline)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages compression)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system python))
+(define-public z
+ (package
+ (name "z")
+ (version "1.11")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rupa/z.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13zbgkj6y0qhvn5jpkrqbd4jjxjr789k228iwma5hjfh1nx7ghyb"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gzip" ,gzip)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (delete 'check)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (man-path (string-append out "/share/man/man1"))
+ (install-path (string-append out "/bin")))
+ (mkdir-p install-path)
+ (copy-file "z.sh" (string-append install-path "/z.sh"))
+ (chmod (string-append install-path "/z.sh") #o755)
+
+ (mkdir-p man-path)
+ (invoke "gzip" "z.1")
+ (copy-file "z.1.gz" (string-append man-path "/z.1.gz"))
+ (chmod (string-append man-path "/z.1.gz") #o744)))))))
+ (synopsis "Jump about directories")
+ (description
+ "Tracks your most used directories, based on freecency. After a short
+learning phase, z will take you to the most frecent directory that matches
+ALL of the regexes given on the command line in order.")
+ (home-page "https://github.com/rupa/z")
+ (license license:expat)))
+
(define-public envstore
(package
(name "envstore")
--
2.23.0