(address . guix-patches@gnu.org)
* gnu/packages/bootloaders (u-boot-tools)[check]: Remove x86 tests.
[check-x86]: New phase with x86 tests.
[patch]: Patch test-imagetools.sh to test binaries to be installed.
---
gnu/packages/bootloaders.scm | 23 +++++++++++++++++------
1 file changed, 17 insertions(+), 6 deletions(-)
Toggle diff (43 lines)
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index b4eabaea48..0cd72fb44c 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -442,6 +442,10 @@ also initializes the boards (RAM etc).")
(("def test_ctrl_c")
"@pytest.mark.skip(reason='Guix has problems with SIGINT')
def test_ctrl_c"))
+ ;; Test against the tools being installed rather than tools built
+ ;; for "sandbox" target.
+ (substitute* "test/image/test-imagetools.sh"
+ (("BASEDIR=sandbox") "BASEDIR=."))
(for-each (lambda (file)
(substitute* file
;; Disable signatures, due to GPL/Openssl
@@ -484,12 +488,19 @@ def test_ctrl_c"))
(delete 'check)
(add-after 'install 'check
(lambda* (#:key make-flags test-target #:allow-other-keys)
- (apply invoke "make" "mrproper" make-flags)
- (setenv "SDL_VIDEODRIVER" "dummy")
- (setenv "PAGER" "cat")
- (apply invoke "make" test-target make-flags)
- (symlink "build-sandbox_spl" "sandbox")
- (invoke "test/image/test-imagetools.sh"))))))
+ (invoke "test/image/test-imagetools.sh")))
+ ;; Only run full test suite on x86 systems, as many tests assume
+ ;; x86.
+ ,@(if (string-match "^(x86_64|i686)-linux"
+ (or (%current-target-system)
+ (%current-system)))
+ '((add-after 'check 'check-x86
+ (lambda* (#:key make-flags test-target #:allow-other-keys)
+ (apply invoke "make" "mrproper" make-flags)
+ (setenv "SDL_VIDEODRIVER" "dummy")
+ (setenv "PAGER" "cat")
+ (apply invoke "make" test-target make-flags))))
+ '()))))
(description "U-Boot is a bootloader used mostly for ARM boards. It
also initializes the boards (RAM etc). This package provides its
board-independent tools.")))
--
2.20.1
-----BEGIN PGP SIGNATURE-----
iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXMZ1vAAKCRDcUY/If5cW
qlmPAQDBv5y0ZYfGgMj0LIh+ZlAnhnxEDakVWpCiEHdba0ILDAD9FnZFX3SwpPWW
VftsjbyYG99e1fWv3E+pnPdkcpj77AU=
=mKQm
-----END PGP SIGNATURE-----