(address . guix-patches@gnu.org)
Fixes CVE-2019-{3855,3856,3857,3858,3859,3860,3861,3862,3863}.
---
gnu/packages/ssh.scm | 16 ++++++++++++++++
1 file changed, 16 insertions(+)
Toggle diff (36 lines)
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index dc81736f06..ec81844b93 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -111,6 +111,7 @@ applications.")
(define-public libssh2
(package
(name "libssh2")
+ (replacement libssh2-1.8.1)
(version "1.8.0")
(source (origin
(method url-fetch)
@@ -143,6 +144,21 @@ a server that supports the SSH-2 protocol.")
(license license:bsd-3)
(home-page "https://www.libssh2.org/")))
+(define-public libssh2-1.8.1
+ (package
+ (inherit libssh2)
+ (version "1.8.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://www.libssh2.org/download/libssh2-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0ngif3ynk6xqzy5nlfjs7bsmfm81g9f145av0z86kf0vbgrigda0"))
+ (patches
+ (search-patches "libssh2-fix-build-failure-with-gcrypt.patch"))))))
+
(define-public openssh
(package
(name "openssh")
--
2.21.0