(address . guix-patches@gnu.org)
From 6f88f586ca51d5fba375ef52fec8a73f95911bd0 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Thu, 7 Feb 2019 22:04:16 -0600
Subject: [PATCH 3/5] gnu: Add python-jsonrpc-server.
* gnu/packages/python-xyz.scm (python-jsonrpc-server): New variable.
---
gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
Toggle diff (35 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9efbbeba8..5c7241621 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2523,6 +2523,28 @@ Language (TOML) configuration files.")
"The Python Language Server (pyls) is an implementation of the Python 3 language specification for the LSP. This tool is used in many text-editing environments to provide a complete and integrated feature-set for programming Python effectively.")
(license license:expat)))
+(define-public python-jsonrpc-server
+ (package
+ (name "python-jsonrpc-server")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-jsonrpc-server" version))
+ (sha256
+ (base32
+ "0m4ykpcdy52x37n1ikysp07j7p8ialcdvvvsrjp3545sn7iiid09"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-future" ,python-future)
+ ("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)))
+ (home-page
+ "https://github.com/palantir/python-jsonrpc-server")
+ (synopsis "JSON RPC 2.0 server library")
+ (description "An implementation of the JSON RPC 2.0 server library for interoperability with Python.")
+ (license license:expat)))
+
(define-public python-black
(package
(name "python-black")
--
2.20.1