(address . guix-patches@gnu.org)(name . Jelle Licht)(address . jlicht@fsfe.org)
* gnu/packages/emacs.scm (emacs-with-editor): Update to 2.8.0.
[source]: Use 'git-fetch'.
---
gnu/packages/emacs.scm | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)
Toggle diff (30 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 7181d05a3..335d315d3 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -433,16 +433,16 @@ configuration files, such as .gitattributes, .gitignore, and .git/config.")
(define-public emacs-with-editor
(package
(name "emacs-with-editor")
- (version "2.7.3")
+ (version "2.8.0")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/magit/with-editor/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/magit/with-editor.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1ln2s0kckzkv50qmr6x1kb2j30cfjii0vs6lpghg7ff4lav8jqgh"))))
+ "1bbzvxnjpxqyvi808isld025b3pcidn4r2xf8hnk9bmzcfdvdr6q"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-dash" ,emacs-dash)))
--
2.20.1