(address . guix-patches@gnu.org)(name . Brett Gilio)(address . brettg@posteo.net)
---
gnu/packages/emacs.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)
Toggle diff (46 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index c6008e6a9..72112cfc0 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -40,6 +40,7 @@
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2018 Alex Branham <alex.branham@gmail.com>
;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
+;;; Copyright © 2018 Brett Gilio <bgilio@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9837,6 +9838,31 @@ CSS, JavaScript, JSON.")
throw a shell history.")
(license license:gpl3+))))
+(define-public emacs-webpaste
+ (package
+ (name "emacs-webpaste")
+ (version "20180815.1855")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://melpa.org/packages/webpaste-"
+ version
+ ".el"))
+ (sha256
+ (base32
+ "0afbyrqs0hk9b5a7g75lar31v8bmmbgvcl64z0i52bi78vz7fdv8"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-request" ,emacs-request)))
+ (home-page "https://github.com/etu/webpaste.el")
+ (synopsis "Paste to pastebin-like services")
+ (description "This mode allows to paste whole buffers or parts of buffers to
+pastebin-like services. It supports more than one service and will
+failover if one service fails. More services can easily be added
+over time and prefered services can easily be configured.")
+ (license license:gpl3+)))
+
(define-public emacs-discover-my-major
(package
(name "emacs-discover-my-major")
--
2.19.1