Björn Höfling <bjoern.hoefling@bjoernhoefling.de> writes:
Toggle quote (27 lines)
> On Sun, 5 Aug 2018 15:43:20 +0100
> Christopher Baines <mail@cbaines.net> wrote:
>
>> From: Ben Woodcroft <donttrustben@gmail.com>
>>
>> * gnu/packages/ruby.scm (ruby-oj): New variable.
>>
>> Signed-off-by: Christopher Baines <mail@cbaines.net>
>> ---
>> gnu/packages/ruby.scm | 36 ++++++++++++++++++++++++++++++++++++
>> 1 file changed, 36 insertions(+)
>>
>> diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
>> index a06be3e26..508bbe8c3 100644
>> --- a/gnu/packages/ruby.scm
>> +++ b/gnu/packages/ruby.scm
>> @@ -3161,6 +3161,42 @@ unacceptable HTML and/or CSS from a string.")
>> (home-page "https://github.com/rgrove/sanitize/")
>> (license license:expat)))
>>
>> +(define-public ruby-oj
>> + (package
>> + (name "ruby-oj")
>> + (version "3.6.0")
>
> 3.6.5 is already available.
I've sent some updated patches now, and I've updated to the latest version.
Toggle quote (16 lines)
>> + (source
>> + (origin
>> + (method url-fetch)
>> + ;; Version on rubygems.org does not contain Rakefile, so
>> download from
>> + ;; GitHub instead.
>> + (uri (string-append "https://github.com/ohler55/oj/archive/v"
>> + version ".tar.gz"))
>> + (file-name (string-append name "-" version ".tar.gz"))
>> + (sha256
>> + (base32
>> + "1vhjkmnyllkiwpwqh6swbam826ch2vhrjqmbys2ki6wh48vzknlb"))))
>
> I forgot: Is this checksum-stable or should we switch to
> git-fetch here?
Toggle quote (24 lines)
>> + (build-system ruby-build-system)
>> + (arguments
>> + '(#:test-target "test_all"
>> + #:phases
>> + (modify-phases %standard-phases
>> + (add-before 'check 'disable-bundler
>> + (lambda _
>> + (substitute* "Rakefile"
>> + (("Bundler\\.with_clean_env") "1.times")
>> + (("bundle exec ") "")))))))
>> + (native-inputs
>> + `(("bundler" ,bundler)
>> + ("ruby-rspec" ,ruby-rspec)
>> + ("ruby-rake-compiler" ,ruby-rake-compiler)))
>> + (synopsis "JSON parser for Ruby optimized for speed")
>> + (description
>> + "Oj is a JSON parser and generator for Ruby, where the encoding
>> and +decoding of JSON is implemented as a C extension to Ruby.")
>> + (home-page "https://www.ohler.com/oj")
>
> I had trouble reaching that site over httpS. http was fine.
> Is this permanent or temporary?
> rubygems also has http as homepage.
Yeah, my bad, I think I followed the linter without thinking.
Toggle quote (8 lines)
>> + (license license:expat)))
>
> ./ext/oj/fast.c: BSD (3 clause)
> ./ext/oj/hash.c: BSD (3 clause)
> ./ext/oj/hash.h: BSD (3 clause)
> ./ext/oj/hash_test.c: BSD (3 clause)
> and others
Good spot, I've tried to improve the license information now.
Toggle quote (2 lines)
> As above, guix build --rounds=2 -K complained, but diffoscope showed no dfference.
I do see some differences with diffoscope, but I haven't looked in to
them yet.
-----BEGIN PGP SIGNATURE-----
iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAluFssFfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XcjLRAAqEXgVDadJkHPL9IqZE4XRCKw5/yTbF3U+xil5zGBYnYfCayF1bgABK1m
NkySnz0zYhspdzngahzGFR/nNeYu9zHJeutdV2lXCy+S/X0UZPr/E9JAWFByZd8F
hT0mY9A687zBJ4a3IeOK7iQhZxZInwiCieBlPS7don7mESifnp5gq0Ht0SUB/Ces
sTOOj/xB2nPDeorhFJIx7Ssg7HVnRspeAH16/CJHeAgXGGryT99pdzOfId73Essc
aUD9EhEjGmB2y5f6zStn2HrrGvsd5msK8pwiU8FCuCz4YdmkoVoaHsraEyf2CGv/
5sP6oY1wNJoDCOdE3uF8LPoUwYhEhAFSu+zj3kgQ4k1qIns0KbEdi8hwBRk3gweG
b8TlyygVva5gAe5uQYIEVTfj7HJjveEiage3il7LH86XEy5YRXG6uqFYw70XeRJM
/+BvcxevkUL0PD3W/Kw4hsvpm8mzZKHW97qaz110CgqW94vnDG53zteMF4ANpTFM
vYpXJgnTpVXDWttwzlkAtdwlFkT+7fmp67nNMV8o3xCUmx1k90UgcoT2FO0lMk4L
IAAu6NMbC0+vTqiCTcIMJhyMzroRhrIXMztYon9NpyoHrpFTxLgrtCmvq5yRFssu
aq9UDj1duDNDm2OtaB5gM/slXL1sdwkWaL/6X9QCNLTM22p2m+o=
=+BHN
-----END PGP SIGNATURE-----