(address . bug-guix@gnu.org)
Hello Guix,
I have issue with building loop after changing pulseaudio and
emacs-ido-completing-read+ packages.
pulseaudio
Toggle diff (141 lines)
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index 21753cf3f..3c9659b73 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -41,6 +41,7 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages m4)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages qt)
#:use-module (gnu packages xiph))
(define-public libsndfile
@@ -173,7 +174,8 @@ rates.")
("fftwf" ,fftwf)
("avahi" ,avahi)
("eudev" ,eudev) ;for the detection of hardware audio devices
- ("check" ,check)))
+ ("check" ,check)
+ ("python-pyqt" ,python-pyqt)))
(native-inputs
`(("pkg-config" ,pkg-config)))
(propagated-inputs
$ make
$ time ./pre-inst-env guix build --verbosity=5 -n --no-substitutes pulseaudio
$ sort -u ~/screenlog.1
--8<---------------cut here---------------start------------->8---
acquiring global GC lock `/var/guix/gc.lock'
acquiring read lock on `/var/guix/temproots/9147'
acquiring write lock on `/var/guix/temproots/9147'
^C
downgrading to read lock on `/var/guix/temproots/9147'
httmakunitime ./pre-inst-env guix build --verbosity=5 -n --no-substitutes pulseaudio
natsu@magnolia ~/src/guix$
real 4m8.823s
sys 0m2.555s
user 4m11.696s
--8<---------------cut here---------------end--------------->8---
emacs-ido-completing-read+
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 4c5dd2ba8..7dee7fedf 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3777,48 +3777,35 @@ restrict the text width to 80 characters.")
(define-public emacs-ido-completing-read+
(package
(name "emacs-ido-completing-read+")
- (version "3.12")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://raw.githubusercontent.com"
- "/DarwinAwardWinner/ido-ubiquitous/v"
- version "/ido-completing-read+.el"))
- (file-name (string-append "ido-completing-read+-" version ".el"))
- (sha256
- (base32
- "1cyalb0p7nfsm4n6n9q6rjmvn6adqc0fq8ybnlj3n41n289dkfjf"))))
+ (version "4.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/"
+ "DarwinAwardWinner/ido-completing-read-plus"
+ "/archive/" "v" version ".tar.gz"))
+ (file-name (string-append "ido-completing-read+-" version ".el"))
+ (sha256
+ (base32
+ "00p6j3chyir3avdgbkb05hw4rr5xd1vyljfhn7pg67jx04z5a0f3"))))
(build-system emacs-build-system)
- (home-page "https://github.com/DarwinAwardWinner/ido-ubiquitous")
- (synopsis "Replacement for completing-read using ido")
+ (propagated-inputs
+ `(("emacs-ido-completing-read+" ,emacs-ido-completing-read+)
+ ("emacs-s" ,emacs-s)
+ ("emacs-memoize" ,emacs-memoize)))
+ (home-page "https://github.com/DarwinAwardWinner/ido-completing-read-plus")
+ (synopsis "Use ido (nearly) everywhere")
(description
- "The ido-completing-read+ function is a wrapper for ido-completing-read.
-Importantly, it detects edge cases that ordinary ido cannot handle and either
-adjusts them so ido can handle them, or else simply falls back to the standard
-Emacs completion function instead.")
+ "@code{emacs-ido-completing-read+} provides ido-style completion for
+almost every function that uses the standard completion function
+completing-read.")
(license license:gpl3+)))
(define-public emacs-ido-ubiquitous
+ ;; Preserve for people already uses `emacs-ido-ubiquitous'
(package
- (name "emacs-ido-ubiquitous")
- (version "3.12")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://raw.githubusercontent.com"
- "/DarwinAwardWinner/ido-ubiquitous/v"
- version "/ido-ubiquitous.el"))
- (file-name (string-append "ido-ubiquitous-" version ".el"))
- (sha256
- (base32
- "197ypji0fb6jsdcq40rpnknwlh3imas6s6jbsvkfm0pz9988c3q2"))))
- (build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-ido-completing-read+" ,emacs-ido-completing-read+)))
- (home-page "https://github.com/DarwinAwardWinner/ido-ubiquitous")
- (synopsis "Use ido (nearly) everywhere")
- (description
- "Ido-ubiquitous enables ido-style completion for almost every function
-that uses the standard completion function completing-read.")
- (license license:gpl3+)))
+ (inherit emacs-ido-completing-read+)
+ (name "emacs-ido-ubiquitous")))
(define-public emacs-yaml-mode
(package
$ make
$ time ./pre-inst-env guix build --verbosity=5 -n --no-substitutes emacs-ido-completing-read+
$ sort -u ~/screenlog.1
--8<---------------cut here---------------start------------->8---
acquiring global GC lock `/var/guix/gc.lock'
acquiring read lock on `/var/guix/temproots/11388'
acquiring write lock on `/var/guix/temproots/11388'
^C
downgrading to read lock on `/var/guix/temproots/11388'
natsu@magnolia ~/src/guix$
real 4m3.979s
sys 0m1.712s
user 4m6.727s
--8<---------------cut here---------------end--------------->8---
Thanks,
Oleg.
-----BEGIN PGP SIGNATURE-----
iQIzBAEBCgAdFiEEc+OyAXw1EaDPCmAPckbhHGm3lWkFAln53N0ACgkQckbhHGm3
lWkbmRAArDgnIr7L4DOU5eIiKxtw7EuRRYAz3bkQtI1I0QUagOq6FILQ44ib4J7h
kxeiQD8Haz4kcAL6DE/0jBPBRaANpG82+Ct5L2kdL9iHRi3CS8eGPpt4Ou1eAMVy
uQv9yWum43bUsxDFNFue6PNX9PQkmBW2fbAFs6ULwtJyZTHzZNSF+fVMY7bhMqZb
yk7PJNSq4naDl/RV2pSNVWiE8x+gQg3Mey3B3wC4475VOdkzTUSS6AzKANAx9/8D
+8SNjVSVWlkVF/+ovsNt2vxtHoNMjHMq+0QsTaOFXKaa14iOik4isrKnIYtMz5ai
KR9rJXYxO4D/HOnCCh+qwkgjuRLl43JwYEStUCG9aud3hCFFcgmmpRrGgLnUJaeA
xNXOxGkZrquFC0LCGHOjIX/CWGyvz1ISsUi8HPaOtDWm4/jpR3Z4//QNOs5Kay7Q
/XhbvQUxrBqbkcX6nmbu9Eal9Dt56NPta1AjoJZgG+9aHvkCSemE+fEluUUTYGlU
fTqKl20g2vchDV0ADlWTPBoyrLgpznCWR0XJsF+Fr8M5CjSmhlo8w63Fw99G1HpE
RCd5L+9fEDwQbu8Kq/J4KaG6qUKbeSCQFn9Oqnv+IOE1hldR+Jmy6GWykeg9+iNU
sh+xHoosU+qLZ3dDyd2NIPbyd4jb+ZBQqmAOxxtH2qsfoD2PPmc=
=LT3C
-----END PGP SIGNATURE-----