(address . bug-guix@gnu.org)
I am trying to build/install Guix 0.13 from sources (git checkout),
using a binary installation of a slightly earlier Guix in a Ubuntu 16.04
host system. Basically I am doing
git checkout v0.13.0
guix environment guix
make check
make install
I have also tried with this the most recent commit on master, with the
same failure.
The trouble starts here:
...
Compiling Scheme modules...
guile: warning: failed to install locale
/gnu/store/2kgp5d4wh40b49gp4qwqh2b4il29gq6g-profile/bin/mkdir -p
'/opt/guix/share/man/man1'
/gnu/store/2kgp5d4wh40b49gp4qwqh2b4il29gq6g-profile/bin/install -c -m
644 ./doc/guix.1 ./doc/guix-archive.1 ./doc/guix-build.1
./doc/guix-challenge.1 ./doc/guix-download.1 ./doc/guix-edit.1
./doc/guix-environment.1 ./doc/guix-gc.1 ./doc/guix-hash.1
./doc/guix-import.1 ./doc/guix-lint.1 ./doc/guix-package.1
./doc/guix-publish.1 ./doc/guix-pull.1 ./doc/guix-refresh.1
./doc/guix-size.1 ./doc/guix-system.1 ./doc/guix-daemon.1
'/opt/guix/share/man/man1'
/gnu/store/2kgp5d4wh40b49gp4qwqh2b4il29gq6g-profile/bin/mkdir -p
'/opt/guix/share/guile/site/2.2'
/bin/bash: line 5: gawk: command not found
sed: couldn't write 47 items to stdout: Broken pipe
/bin/bash: line 5: echo: write error: Broken pipe
/bin/bash: line 5: echo: write error: Broken pipe
/bin/bash: line 5: echo: write error: Broken pipe
/bin/bash: line 5: echo: write error: Broken pipe
...
I get lots of copies of these "Broken pipe" lines. Then:
...
/bin/bash: line 5: echo: write error: Broken pipe
/bin/bash: line 5: echo: write error: Broken pipe
/bin/bash: line 5: echo: write error: Broken pipe
/bin/bash: line 5: echo: write error: Broken pipe
/gnu/store/2kgp5d4wh40b49gp4qwqh2b4il29gq6g-profile/bin/mkdir -p
'/opt/guix/share/guile/site/2.2'
/bin/bash: line 5: gawk: command not found
sed: couldn't flush stdout: Broken pipe
/gnu/store/2kgp5d4wh40b49gp4qwqh2b4il29gq6g-profile/bin/mkdir -p
'/opt/guix/lib/guile/2.2/site-ccache'
/bin/bash: line 5: gawk: command not found
sed: couldn't write 47 items to stdout: Broken pipe
/bin/bash: line 5: echo: write error: Broken pipe
/bin/bash: line 5: echo: write error: Broken pipe
/bin/bash: line 5: echo: write error: Broken pipe
...
and another round of broken pipes. But the initial problem seems to be
that gawk is not found. It is available in my build environment, but
apparently that's not where it is looked for.
Konrad.