(address . bug-guix@gnu.org)
Hi,
Our current java does not support swing. To reproduce, first install
java and clojure. Then start the clojure repl by running:
$ ~/.guix-profile/bin/java -cp ~/.guix-profile/share/java/clojure-1.8.0.jar clojure.main
Then try the repl by typing:
=> (+ 1 2 3)
6
Now run:
=> (javax.swing.JOptionPane/showMessageDialog nil "Hello World")
NullPointerException sun.awt.FontConfiguration.getVersion (FontConfiguration.java:1264)
Note that the above test case is taken from
In contrast, if we replace ~/.guix-profile/bin/java by /usr/bin/java in
the command, we do not get a nullpointerexception (my base distro is
debian testing). So there should be a problem in our java build. Any
ideas?
Thanks,
Alex